【root】Xperia GX “LockedBootLoader” with CyanogenMod 改 RUN!!!【成功】

154氏に改めて深く感謝。
例の場所の>>132です。

————— >>132 —————

CMをほぼ常用レベルまで調整しました。

変更点
・カメラが機能するように
・近接センサーと照度センサーが動くように
・Wi-FiのMACアドレスを正しく読み込めていなかった問題を解消
・イヤホンジャック挿入を検出するように
・PowerHALを更新
・ramdiskを調整
・build.propを整理
・9.2.A.1.205のカーネルも一緒に焼くように
・Trebuchet LauncherのGravityBoxによるナビバー透過対応

既知の不具合
・通知LEDが光らない
・Sonyロゴが光らない
->lightsHALのCM用wrapperが問題。wrapperを外すとロゴは光るが、LEDが常時点灯になる。
・CWMに入るのに一手間かかる

導入
1.(推奨)現環境バックアップ
2.(必須)CM10.2
https://www.mediafire.com/?751x4c69ppnpe3n
3.(推奨)CWM-cDM
https://www.mediafire.com/?07b6k6f4qgh6x7q
4.(必須)hijack-ramdisk
https://www.mediafire.com/?og55pgt0a53zzb9
5.(好みで)GAPPS
http://d-h.st/9Nv
6.(必須)Wipe Data
7.再起動
8.初期設定を済ませたら、一度再起動(NFCサービスが初回起動時は暴走するため)
9.完了

ひとつ前のROMからデータを引き継ぐこともできますが、ランチャーにカメラアイコンが表示されないので、きれいにワイプすることをオススメします。
(Nexus7 2012用のカメラショートカットアプリを入れる手もあります。)

————— ここまで —————

キタ━━━━(゚∀゚)━━━━!!

書いてある通りに導入したらいけました。
前回失敗した関係上一度FTF焼いてまっさらな.103にした後でCubeさん製rootKit使ってCWM入れてfix_chager入れてからやったけど。

失敗時はSONYロゴをループしちゃってたけど、今回はスパナアイコンと青いプログレスバーみたいなのがしばらく出てて、数分待ちました。
CMのブートアニメかっこいいね!

もともとCM自体Androidベースなので操作に困ることはないと思います。
CMカメラも「Focal (Beta)」で予習してあったんで良し。

Gappsは入れました。
CMにすると当然Xperia独自カスタムなんぞされないので、QuickSettingsパネルが登場。ロック画面もAndroidみたいなサークル型してます。

初CMだったのでアカウント作りました。
設定項目はなんだか最新Xperiaみたいと思ったけど個人設定の一部とかAndroidが逆輸入したんでしょうか?

バッチリ。だと思う。たぶん。

QuickSettingsパネルは設定から並び替え、追加、削除できます。

ほかにも色々機能があったのでじっくり触ってみようと思います。

そんな感じ!

3 Comments

匿名

.103を焼いて手順通りCM10を入れたのですが、ブルっとして青いランプが付きSONYロゴが出たところで止まって起動しません。
なにか解決方法はないでしょうか?

返信する
tomandroid

SONYロゴ出る前だったか後だったか覚えてませんが、10分くらい放置してみました?
僕のGXで、

失敗した時→いくら待っても真っ暗またはSONYロゴループ
成功した時→三角形のアイコンとTWRPみたいなプログレスバーが出現

となりました。

切り分け方法としては、

①ファルをDLし直す
②ブラウザを変えてDLし直す(端末で直接DLしてダメならPCでDLして転送する)
③作業前に「SDに」バックアップを取った上で内部ストレージを完全に初期化(ftf→rootKit→CWM→リカバリへ再起動→Wipe→再起動→リカバリへ再起動→CM導入開始)
④祈る

くらいでしょうか…。

返信する

コメントを残す

メールアドレスが公開されることはありません。